Месяц: Сентябрь 2013

Обход дерева значений

Процедура ОбработкаСтрокиЗагрузки(Строки, Буфер, Игнорировать) Для Каждого Стр ИЗ Строки Цикл Если Строки.Количество() > 0 Тогда ОбработкаСтрокиЗагрузки(Стр.Строки, Буфер, Игнорировать); КонецЕсли; Если Не ЗначениеЗаполнено(Стр.Номенклатура) И Игнорировать Тогда Продолжить; КонецЕсли; СтрокаБуфера = Буфер.Добавить(); СтрокаБуфера.Ссылка = Стр.Номенклатура; СтрокаБуфера.НовоеНаименование = Стр.Наименование; КонецЦикла; КонецПроцедуры